Как отучить дебиан делать поиск хостов по ipv6 при попытке обновиться?

аватар: Administrator
Administrator
Админ сайта
Не в сети
Зарегистрирован: 29/12/2009

сейчас уже всё нормализовалось, но в тот раз почему-то ipv6 работал вместо ipv4. вот я и хотел поинтересоваться, мож есть продвинутые линуксоиды на форуме.. )

Ош http://ftp.debian.org squeeze Release.gpg
Невозможно инициализировать соединение с ftp.debian.org:80 (2001:610:1908:a000::149:226). - connect (101: Сеть недоступна) [IP: 2001:610:1908:a000::149:226 80]
странное поведение операционки, как мне показалось

Вопрос задан пользователем Decos.

аватар: Administrator
Administrator
Админ сайта
Не в сети
Зарегистрирован: 29/12/2009

UP

аватар: DecoS
DecoS
статус не установлен.
Не в сети
Зарегистрирован: 05/03/2010

Administrator пишет:
UP

интересно, что в данном контексте означает сообщение? Smile

аватар: Administrator
Administrator
Админ сайта
Не в сети
Зарегистрирован: 29/12/2009

Оживление темы.
PS. флуд прекращаем)

аватар: zamickaj_l
zamickaj_l
лицевой счет 8517
Не в сети
Зарегистрирован: 19/05/2011

Я не линуксоидша, но в инете вот что есть, может поможет

Способ #1
Отредактировать файл /etc/modprobe.d/blacklist, добавив в конец его строчку:
blacklist ipv6
затем # reboot

Способ #2
/etc/sysctl.d/bindv6only.conf
В нём меняем значение net.ipv6.bindv6only на 0.
Помогает там, где разработчики забыли про IPv6 (многие Java-приложения).

Способ #3
в /etc/default/grub написать
GRUB_CMDLINE_LINUX="ipv6.disable=1"
после этого выполнить update-grub2

Способ #4
Добавить строку “blacklist ipv6” в файл /etc/modprobe.d/blacklist.
Отредактировать файл /etc/modprobe.d/aliases, закомментировать строку “alias net-pf-16-proto-13 ip6_queue” и добавить две строки: “alias net-pf-10 off“, “alias ipv6 off“.
При использовании четвертого метода, каждый раз при загрузке операционной системы будет выходить сообщение “modprobe: WARNING: not loading blacklisted module ipv6“. Ничего страшного в этом нет.

Чистоплотность - это чисто масса деленная на чисто объем

X
Загрузка